Scheduled Maintenance - ClaimShop and ClaimsCORE & HUB

Scheduled for May 30, 07:00 - 18:00 CEST

Update

The previously scheduled maintenance work on the 18/4 has been rescheduled to 30/5.

During this maintenance window, users may experience service disruptions, and we recommend minimizing use of applications while work is in progress.

We will provide updates here once maintenance is complete. Thank you for your patience and understanding.
Posted Apr 15, 2026 - 15:12 CEST

Update

As a reminder, our scheduled maintenance will take place this coming weekend.

During this time, we recommend minimizing use of applications, as users may experience service disruptions while work is in progress.

We will share an update here once maintenance is complete. Thank you for your continued patience and understanding.
Posted Apr 14, 2026 - 09:49 CEST

Scheduled

We will be using this time to perform the necessary maintenance.

During this maintenance period, users may experience disruption in services.
Once maintenance is completed we will provide the information here.

We appreciate your patience and understanding.

Regards Scalepoint
Posted Mar 13, 2026 - 15:42 CET
This scheduled maintenance affects: ClaimShop (All (Entire system affected)) and ClaimsCORE and HUB (All (Entire system affected)).